🔍 CVE-2002-2142

7.5
CVSS Score
HIGH
2002-12-31
2026-06-16 22:00
✅ 완료

🇰🇷 한글 설명

BEA WebLogic Server 및 Express 6.0에서 7.0.0.1 버전 사이를 7.0 Service Pack 1로 업그레이드할 때 발생하는 보안 취약점입니다. Servlet 2.3 사양의 문서화되지 않은 확장이 특정 URL 패턴에서 '/' 문자를 앞에 붙이지 않아, 애플리케이션의 역할 매핑 및 정책 적용을 방해합니다.

💡 쉬운 설명

웹 서버를 업데이트하는 과정에서 주소 체계에 오류가 생겨 보안 규칙이 제대로 작동하지 않는 문제입니다. 이로 인해 권한이 없는 사용자가 보호된 페이지에 접근할 수 있는 위험이 있습니다.

🇺🇸 원문 (English)

An undocumented extension for the Servlet mappings in the Servlet 2.3 specification, when upgrading to WebLogic Server and Express 7.0 Service Pack 1 from BEA WebLogic Server and Express 6.0 through 7.0.0.1, does not prepend a "/" character in certain URL patterns, which prevents the proper enforcement of role mappings and policies in applications that use the extension.

📍 영향받는 시스템

BEA WebLogic Server and Express 6.0 through 7.0.0.1 (upgraded to 7.0 SP1)

⚔️ 공격 벡터

특정 URL 패턴을 조작하여 보안 정책 및 역할 매핑을 우회하는 방식

🛡️ 대응 방법

취약점이 해결된 최신 패치를 적용하거나 보안 정책이 올바르게 적용되도록 구성 확인

🔧 검증 코드

현재 설치된 WebLogic Server의 버전을 확인하여 취약한 버전 범위에 해당하는지 대조합니다.

Shell / Script
java -version 2>&1 | grep -i 'WebLogic' || echo 'Check WebLogic version via management console'

📊 CVSS Vector String

CVSS Vector
AV:N/AC:L/Au:N/C:P/I:P/A:P

💻 영향받는 소프트웨어

IBM WebSphere Application Server