🔍 CVE-2005-0200

7.5
CVSS Score
HIGH
2005-05-02
2026-04-16 00:27
✅ 완료

🇰🇷 한글 설명

TikiWiki 1.8.5 이전 버전은 임시 디렉토리에 업로드되는 파일에 대한 검증이 부족하여, 원격 공격자가 임의의 PHP 스크립트를 업로드하고 실행할 수 있는 취약점이다. CVE-2004-1386과는 다른 별개의 취약점이다.

💡 쉬운 설명

TikiWiki 웹 애플리케이션이 임시 폴더에 업로드되는 파일을 제대로 확인하지 않아서, 악의적인 사람이 위험한 PHP 코드를 실행시킬 수 있다. 이를 통해 웹서버 전체가 장악될 수 있는 심각한 문제다.

🇺🇸 원문 (English)

TikiWiki before 1.8.5 does not properly validate files that have been uploaded to the temp directory, which could allow remote attackers to upload and execute arbitrary PHP scripts, a different vulnerability than CVE-2004-1386.

📍 영향받는 시스템

TikiWiki versions before 1.8.5 (1.8.4, 1.8.3, and all earlier versions)

⚔️ 공격 벡터

Remote attacker uploads malicious PHP script to temp directory bypassing file validation checks and executes it through web access

🛡️ 대응 방법

Upgrade TikiWiki to version 1.8.5 or later and implement strict file upload validation

🔧 검증 코드

If grep returns version strings matching 1.0-1.8.4 pattern, system is vulnerable; no output indicates version 1.8.5+ or TikiWiki not installed

Shell / Script
find / -type f -name "version.php" -path "*/tiki*" 2>/dev/null | xargs grep -E "1\.[0-7]|1\.8\.[0-4]" 2>/dev/null | head -1

📊 CVSS Vector String

CVSS Vector
AV:N/AC:L/Au:N/C:P/I:P/A:P

💻 영향받는 소프트웨어

PHP