🇰🇷 한글 설명
phpMyAdmin의 Swekey 인증 라이브러리에서 세션을 제대로 관리하지 못해 공격자가 쿼리 스트링으로 SESSION 배열과 다른 전역 변수를 조작할 수 있는 취약점입니다. 인증 우회 및 세션 탈취가 가능합니다.
💡 쉬운 설명
phpMyAdmin에서 사용자 로그인 정보를 보관하는 '세션'을 웹 주소의 매개변수로 바꿀 수 있습니다. 이를 이용하면 다른 사람 계정으로 접근하거나 관리자 권한을 빼앗을 수 있습니다.
🇺🇸 원문 (English)
libraries/auth/swekey/swekey.auth.lib.php in phpMyAdmin 3.x before 3.3.10.3 and 3.4.x before 3.4.3.2 does not properly manage sessions associated with Swekey authentication, which allows remote attackers to modify the SESSION superglobal array, other superglobal arrays, and certain swekey.auth.lib.php local variables via a crafted query string, a related issue to CVE-2011-2505.
📍 영향받는 시스템
phpMyAdmin 3.x (< 3.3.10.3), 3.4.x (< 3.4.3.2) with Swekey authentication enabled
⚔️ 공격 벡터
Crafted query string parameters to manipulate SESSION superglobal array without proper validation
🛡️ 대응 방법
Upgrade phpMyAdmin to version 3.3.10.3 or 3.4.3.2 or later; disable Swekey authentication if not needed
🔧 검증 코드
If output shows swekey auth library, the vulnerable component is installed; cross-check phpMyAdmin version with: cat /usr/share/phpmyadmin/ChangeLog | head -20
grep -r 'swekey.auth' /usr/share/phpmyadmin/ 2>/dev/null | head -1