🔍 CVE-2013-0224

4.4
CVSS Score
MEDIUM
2013-03-19
2026-04-29 01:13
✅ 완료

🇰🇷 한글 설명

Drupal의 Video 모듈이 FFmpeg 트랜스코더를 사용할 때 임시 PHP 파일의 권한이 부실하여 로컬 사용자가 임의의 PHP 코드를 실행할 수 있는 취약점입니다. 7.x-2.9 버전 이전에 해당하며, 웹 서버 권한으로 악성 코드 실행이 가능합니다.

💡 쉬운 설명

Drupal 동영상 처리 기능(FFmpeg)에서 임시 파일 권한 설정이 부실해 공격자가 악의적 코드를 주입할 수 있습니다. 웹사이트 서버를 제어할 수 있게 됩니다.

🇺🇸 원문 (English)

The Video module 7.x-2.x before 7.x-2.9 for Drupal, when using the FFmpeg transcoder, allows local users to execute arbitrary PHP code by modifying a temporary PHP file.

📍 영향받는 시스템

Drupal Video module 7.x-2.0 through 7.x-2.8 (FFmpeg transcoder enabled)

⚔️ 공격 벡터

Local attacker modifies temporary PHP files in FFmpeg transcoder working directory to inject and execute arbitrary PHP code

🛡️ 대응 방법

Upgrade to Video module 7.x-2.9 or later; set proper file permissions (chmod 700) on temporary directories; restrict local access

🔧 검증 코드

version 값이 7.x-2.9 이상이면 안전하고, 7.x-2.8 이하면 취약합니다.

Shell / Script
find /var/www -path '*/modules/video/video.info' -exec grep 'version' {} \; 2>/dev/null

📊 CVSS Vector String

CVSS Vector
AV:L/AC:M/Au:N/C:P/I:P/A:P

💻 영향받는 소프트웨어

PHP