🔍 CVE-2016-10147

5.5
CVSS Score
MEDIUM
2017-01-18
2026-05-13 00:24
✅ 완료

🇰🇷 한글 설명

Linux 커널의 암호화 모듈(mcryptd.c)에서 AF_ALG 소켓으로 호환되지 않는 알고리즘을 사용할 경우 NULL 포인터 참조로 인해 시스템이 충돌하는 취약점입니다. 로컬 사용자가 md5 같은 부적절한 알고리즘을 지정하여 denial of service 공격을 수행할 수 있습니다.

💡 쉬운 설명

Linux 운영체제의 암호화 기능에서 잘못된 알고리즘을 사용하면 시스템이 충돌합니다. 컴퓨터에 로그인한 사용자라면 누구나 이를 악용하여 시스템을 먹통으로 만들 수 있습니다.

🇺🇸 원문 (English)

crypto/mcryptd.c in the Linux kernel before 4.8.15 allows local users to cause a denial of service (NULL pointer dereference and system crash) by using an AF_ALG socket with an incompatible algorithm, as demonstrated by mcryptd(md5).

📍 영향받는 시스템

Linux kernel 4.8.15 이전 버전 (커널 2.6.38 이후 영향받음)

⚔️ 공격 벡터

로컬 사용자가 AF_ALG 소켓으로 mcryptd에 호환되지 않는 암호 알고리즘을 전달하여 NULL pointer dereference 유발

🛡️ 대응 방법

Linux kernel을 4.8.15 이상으로 업그레이드하거나 배포판 커널 패치 설치

🔧 검증 코드

현재 커널 버전을 확인하여 4.8.15 이상이면 'Patched', 미만이면 'Vulnerable' 출력. 버전이 4.8.15 이상이거나 배포판에서 백포트 패치를 적용했으면 안전합니다.

Shell / Script
uname -r | awk -F. '{if($1*1000+$2>4008||($1==4&&$2==8&&$3>=15)){print "Patched"}else{print "Vulnerable"}}'

📊 CVSS Vector String

CVSS Vector
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

Linux Kernel