🔍 CVE-2016-5632

4.9
CVSS Score
MEDIUM
2016-10-25
2026-05-06 22:30
✅ 완료

🇰🇷 한글 설명

Oracle MySQL 5.7.14 이전 버전의 옵티마이저(쿼리 최적화 엔진)에 존재하는 미명시 취약점입니다. 원격 관리자가 특정 쿼리를 실행하여 데이터베이스 서비스를 중단시킬 수 있습니다.

💡 쉬운 설명

MySQL 데이터베이스의 쿼리 처리 과정에서 문제가 발생하여, 관리자 권한을 가진 공격자가 데이터베이스를 마비시킬 수 있습니다. 데이터는 안전하지만 서비스가 중단되는 문제가 발생합니다.

🇺🇸 원문 (English)

Unspecified vulnerability in Oracle MySQL 5.7.14 and earlier allows remote administrators to affect availability via vectors related to Server: Optimizer.

📍 영향받는 시스템

Oracle MySQL 5.7.14 이전 모든 5.7.x 버전

⚔️ 공격 벡터

원격 관리자가 악의적인 쿼리를 실행하여 옵티마이저를 과부하시켜 DoS 유발

🛡️ 대응 방법

MySQL을 5.7.15 이상으로 업그레이드

🔧 검증 코드

vulnerable이 출력되면 5.7.14 이하 버전으로 취약함. patched가 출력되면 5.7.15 이상으로 안전함.

Shell / Script
mysql --version 2>/dev/null | grep -oP '\d+\.\d+\.\d+' | awk -F. '{if($1==5 && $2==7 && $3<=14) print "vulnerable"; else print "patched"}'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

MySQL