🔍 CVE-2016-7054

7.5
CVSS Score
HIGH
2017-05-04
2026-06-17 00:52
✅ 완료

🇰🇷 한글 설명

OpenSSL 1.1.0c 이전 버전에서 CHACHA20-POLY1305 암호스위트를 사용하는 TLS 연결이 DoS 공격에 취약합니다. 공격자는 특수 제작된 큰 페이로드를 전송하여 데이터를 손상시키고 OpenSSL 프로세스를 강제 종료할 수 있습니다. 이 취약점은 DoS 이상으로는 악용될 수 없습니다.

💡 쉬운 설명

OpenSSL의 특정 암호화 방식을 사용하는 보안 연결을 공격자가 고장낼 수 있습니다. 나쁜 데이터를 보내 프로그램을 멈추게 할 수 있지만, 정보를 훔치거나 다른 피해를 줄 수는 없습니다.

🇺🇸 원문 (English)

In OpenSSL 1.1.0 before 1.1.0c, TLS connections using *-CHACHA20-POLY1305 ciphersuites are susceptible to a DoS attack by corrupting larger payloads. This can result in an OpenSSL crash. This issue is not considered to be exploitable beyond a DoS.

📍 영향받는 시스템

OpenSSL 1.1.0 ~ 1.1.0b (CHACHA20-POLY1305 암호스위트 사용 시스템)

⚔️ 공격 벡터

원격 공격자가 TLS 연결을 통해 손상된 대용량 페이로드 전송으로 OpenSSL 충돌 유발

🛡️ 대응 방법

OpenSSL을 1.1.0c 이상으로 즉시 업그레이드

🔧 검증 코드

VULNERABLE이 출력되면 취약 버전, PATCHED가 출력되면 1.1.0c 이상으로 패치됨

Shell / Script
openssl version | grep -qE '1\.1\.0[ab]($|[^0-9])' && echo 'VULNERABLE' || echo 'PATCHED'

📊 CVSS Vector String

CVSS Vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

OpenSSL