pysaml2 version 4.4.0 and earlier
Passive observation and analysis of encrypted SAML traffic patterns; attacker can correlate repeated encrypted messages and potentially decrypt sensitive authentication assertions
Upgrade pysaml2 to version 4.5.0 or later; apply security patch that implements unique IV generation per encryption operation
If version shows 4.4.0 or earlier, system is vulnerable. Upgrade to 4.5.0+ to patch the IV reuse vulnerability.
pip show pysaml2 | grep Version
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N