🇰🇷 한글 설명
MySQL Server 5.7.18 이하 버전의 쿼리 최적화 엔진(Optimizer) 취약점으로, 높은 권한의 공격자가 네트워크를 통해 악의적인 쿼리를 실행하면 데이터베이스 서버가 행(hang)되거나 충돌(crash)하여 서비스 거부(DoS) 공격을 초래합니다.
💡 쉬운 설명
MySQL 관리자 권한이 있는 공격자가 특정 쿼리를 실행해 서버를 멈추게 하거나 다운시킬 수 있습니다. 이는 웹사이트나 애플리케이션의 데이터베이스를 사용할 수 없게 만듭니다.
🇺🇸 원문 (English)
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Optimizer). Supported versions that are affected are 5.7.18 and earlier. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.0 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).
📍 영향받는 시스템
MySQL Server versions 5.7.18 and earlier
⚔️ 공격 벡터
High-privileged attacker with network access executes specially crafted SQL queries targeting the Optimizer subcomponent
🛡️ 대응 방법
Upgrade to MySQL 5.7.19 or later; apply official security patches from Oracle
🔧 검증 코드
명령어가 버전을 출력하고 'Vulnerable'을 표시하면 패치 필요, 그 외에는 안전함
mysql --version 2>/dev/null | grep -oE '5\.7\.([0-9]|1[0-8])' && echo 'Vulnerable' || echo 'Not vulnerable or MySQL not installed'