🔍 CVE-2017-7235

8.8
CVSS Score
HIGH
2017-03-23
2026-05-13 00:24
✅ 완료

🇰🇷 한글 설명

cloudflare-scrape 라이브러리 1.6.6~1.7.1 버전에서 악의적인 웹사이트 소유자가 해당 페이지를 스크래핑하는 사용자의 시스템에서 임의의 Python 코드를 실행할 수 있는 원격 코드 실행 취약점이 발견되었습니다. 1.8.0 버전에서 수정되었습니다.

💡 쉬운 설명

나쁜 의도의 웹사이트 소유자가 악성 코드를 심어두면, 그 사이트를 긁어가는 프로그램 사용자의 컴퓨터에서 자신의 코드를 마음대로 실행할 수 있습니다. 웹 크롤링 도구를 사용할 때 매우 위험한 상황입니다.

🇺🇸 원문 (English)

An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. This is fixed in 1.8.0.

📍 영향받는 시스템

cloudflare-scrape 1.6.6, 1.6.7, 1.6.8, 1.6.9, 1.6.10, 1.7.0, 1.7.1

⚔️ 공격 벡터

악의적인 웹사이트에 Python 코드 payload를 삽입하여 cfscrape로 스크래핑하는 사용자의 시스템에서 실행

🛡️ 대응 방법

cloudflare-scrape를 1.8.0 이상으로 즉시 업그레이드 (pip install --upgrade cloudflare-scrape)

🔧 검증 코드

위 명령어가 출력을 반환하면 취약한 버전, 아무것도 출력 안 하면 안전한 버전이 설치되어 있습니다.

Shell / Script
python3 -c "import cfscrape; print(cfscrape.__version__)" 2>/dev/null | grep -E '^1\.[0-7]|^1\.6\.[0-9]'

📊 CVSS Vector String

CVSS Vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Python