🔍 CVE-2018-0733

5.9
CVSS Score
MEDIUM
2018-03-27
2026-06-17 01:31
✅ 완료

🇰🇷 한글 설명

PA-RISC 아키텍처용 OpenSSL의 CRYPTO_memcmp 함수 구현 오류로 인해 각 바이트의 최하위 비트만 비교하는 문제가 발생합니다. 이로 인해 공격자가 인증된 메시지를 위조할 수 있는 가능성이 생기며, 보안 설계에서 보장하는 시도 횟수보다 훨씬 적은 시도로 공격이 가능해집니다.

💡 쉬운 설명

데이터가 일치하는지 확인하는 과정에서 아주 일부분만 검사하는 실수가 발견되었습니다. 이 때문에 해커가 가짜 메시지를 진짜처럼 속여서 통과시키기가 훨씬 쉬워졌습니다.

🇺🇸 원문 (English)

Because of an implementation bug the PA-RISC CRYPTO_memcmp function is effectively reduced to only comparing the least significant bit of each byte. This allows an attacker to forge messages that would be considered as authenticated in an amount of tries lower than that guaranteed by the security claims of the scheme. The module can only be compiled by the HP-UX assembler, so that only HP-UX PA-RISC targets are affected. Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g).

📍 영향받는 시스템

OpenSSL 1.1.0 ~ 1.1.0g (HP-UX PA-RISC 타겟 한정)

⚔️ 공격 벡터

메시지 인증 코드(MAC) 비교 시 발생하는 취약점을 이용한 무차별 대입 공격(Brute-force)

🛡️ 대응 방법

OpenSSL 버전을 1.1.0h 이상으로 업데이트하십시오.

🔧 검증 코드

명령어 결과에 OpenSSL 1.1.0a부터 1.1.0g 사이의 버전이 출력되면 취약한 상태입니다.

Shell / Script
openssl version | grep -E 'OpenSSL 1.1.0[a-g]'

📊 CVSS Vector String

CVSS Vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

💻 영향받는 소프트웨어

OpenSSL