🔍 CVE-2019-10079

7.5
CVSS Score
HIGH
2019-10-22
2026-06-17 02:10
✅ 완료

🇰🇷 한글 설명

Apache Traffic Server에서 HTTP/2 설정 플러드 공격에 취약점이 발견되었습니다. 이전 버전의 Apache Traffic Server는 HTTP/2 프로토콜을 사용하는 클라이언트가 전송하는 설정 프레임의 수를 제한하지 않습니다. 사용자는 Apache Traffic Server 7.1.7, 8.0.4 또는 그 이상의 버전으로 업그레이드해야 합니다.

💡 쉬운 설명

해커가 서버에 가짜 설정 정보를 엄청나게 많이 보내서 서버를 마비시킬 수 있는 문제입니다. 서버가 너무 많은 요청을 처리하느라 힘들어져서 정상적인 서비스를 못 하게 됩니다.

🇺🇸 원문 (English)

Apache Traffic Server is vulnerable to HTTP/2 setting flood attacks. Earlier versions of Apache Traffic Server didn't limit the number of setting frames sent from the client using the HTTP/2 protocol. Users should upgrade to Apache Traffic Server 7.1.7, 8.0.4, or later versions.

📍 영향받는 시스템

Apache Traffic Server 7.1.7 및 8.0.4 미만 버전

⚔️ 공격 벡터

HTTP/2 프로토콜을 이용한 대량의 SETTINGS 프레임 전송 (Flood Attack)

🛡️ 대응 방법

Apache Traffic Server를 7.1.7 또는 8.0.4 이상의 최신 버전으로 업데이트

🔧 검증 코드

출력된 버전 정보가 7.1.7 또는 8.0.4 이상인지 확인합니다.

Shell / Script
apache2-proxy --version 2>/dev/null || httpd -v 2>/dev/null | grep -i 'Apache Traffic Server'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

Apache HTTP Server