🇰🇷 한글 설명
Kubernetes API 서버의 부적절한 입력 검증으로 인해 악의적인 YAML 또는 JSON 페이로드를 전송할 경우 CPU 및 메모리 자원을 과도하게 소모할 수 있습니다. 이로 인해 API 서버가 충돌하거나 서비스 불능 상태에 빠질 수 있으며, 구버전의 경우 익명 사용자도 공격이 가능할 수 있습니다.
💡 쉬운 설명
공격자가 특수하게 조작된 파일을 보내 서버의 컴퓨터 자원을 모두 써버리게 만드는 공격입니다. 이로 인해 서버가 멈추거나 정상적인 서비스를 이용할 수 없게 됩니다.
🇺🇸 원문 (English)
Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable. Prior to v1.14.0, default RBAC policy authorized anonymous users to submit requests that could trigger this vulnerability. Clusters upgraded from a version prior to v1.14.0 keep the more permissive policy by default for backwards compatibility.
📍 영향받는 시스템
Kubernetes v1.0-v1.12, v1.13.12 미만, v1.14.8 미만, v1.15.5 미만, v1.16.2 미만
⚔️ 공격 벡터
권한이 있는 사용자 또는 익명 사용자가 조작된 YAML/JSON 페이로드를 API 서버에 전송
🛡️ 대응 방법
Kubernetes를 취약점이 해결된 버전(v1.13.12, v1.14.8, v1.15.5, v1.16.2 이상)으로 업데이트
🔧 검증 코드
출력된 GitVersion이 취약점이 해결된 보안 패치 버전보다 낮은지 확인
kubectl version --short 2>/dev/null | grep -E 'Build Date|GitVersion'