🔍 CVE-2020-26301

7.5
CVSS Score
HIGH
2021-09-20
2026-06-17 03:08
✅ 완료

🇰🇷 한글 설명

node.js용 ssh2 라이브러리 1.4.0 미만 버전에서 Windows 환경을 대상으로 하는 커맨드 인젝션 취약점이 발견되었습니다. 신뢰할 수 없는 입력값이 취약한 메서드에 전달될 경우 원격 코드 실행(RCE)이 가능할 수 있습니다.

💡 쉬운 설명

윈도우 운영체제에서 특정 프로그램을 사용할 때, 공격자가 악성 명령어를 몰래 끼워 넣어 컴퓨터를 마음대로 조종할 수 있는 문제입니다. 프로그램이 사용자의 입력을 제대로 검사하지 않아 발생하는 보안 허점입니다.

🇺🇸 원문 (English)

ssh2 is client and server modules written in pure JavaScript for node.js. In ssh2 before version 1.4.0 there is a command injection vulnerability. The issue only exists on Windows. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. This is fixed in version 1.4.0.

📍 영향받는 시스템

ssh2 library version < 1.4.0 (Windows only)

⚔️ 공격 벡터

신뢰할 수 없는 입력값을 취약한 ssh2 메서드에 전달하여 명령어를 실행하는 방식

🛡️ 대응 방법

ssh2 라이브러리를 1.4.0 버전 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 결과에서 ssh2의 버전이 1.4.0 미만인지 확인하십시오.

Shell / Script
npm list ssh2

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:N

💻 영향받는 소프트웨어

Node.js