🔍 CVE-2021-21307

8.6
CVSS Score
HIGH
2021-02-11
2026-06-17 03:35
✅ 완료

🇰🇷 한글 설명

Lucee Admin의 특정 버전에서 인증되지 않은 공격자가 원격 코드를 실행할 수 있는 취약점이 발견되었습니다. 이 취약점은 Lucee Server의 Java 기반 동적 스크립팅 언어 처리 과정에서 발생합니다. 해당 문제는 5.3.7.47, 5.3.6.68, 5.3.5.96 버전에서 수정되었습니다.

💡 쉬운 설명

해커가 아이디나 비밀번호 없이도 웹 서버에 몰래 침입하여 마음대로 명령을 내릴 수 있는 위험한 구멍이 발견되었습니다. 이 구멍을 통해 서버의 제어권을 통째로 빼앗길 수 있습니다.

🇺🇸 원문 (English)

Lucee Server is a dynamic, Java based (JSR-223), tag and scripting language used for rapid web application development. In Lucee Admin before versions 5.3.7.47, 5.3.6.68 or 5.3.5.96 there is an unauthenticated remote code exploit. This is fixed in versions 5.3.7.47, 5.3.6.68 or 5.3.5.96. As a workaround, one can block access to the Lucee Administrator.

📍 영향받는 시스템

Lucee Admin 5.3.7.47 미만, 5.3.6.68 미만, 5.3.5.96 미만 버전

⚔️ 공격 벡터

인증되지 않은 원격 공격자가 특수하게 조작된 요청을 통해 원격 코드 실행(RCE)

🛡️ 대응 방법

Lucee를 최신 보안 패치 버전(5.3.7.47, 5.3.6.68, 5.3.5.96 이상)으로 업데이트하거나 Lucee Administrator에 대한 접근을 차단하십시오.

🔧 검증 코드

출력된 버전 번호가 취약점이 해결된 버전(5.3.7.47, 5.3.6.68, 5.3.5.96 이상)인지 확인하십시오.

Shell / Script
curl -s http://localhost:8080/lucee/web-context/version.jsp 2>/dev/null || echo 'Version check failed'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N

💻 영향받는 소프트웨어

IBM WebSphere Application Server