🇰🇷 한글 설명
Spring Cloud Gateway를 사용하는 애플리케이션은 특수하게 제작된 요청을 통해 다운스트림 서비스에 추가 요청을 보낼 수 있는 취약점이 있습니다. 이 취약점은 요청 처리 과정에서 의도하지 않은 추가 통신을 유발할 수 있습니다.
💡 쉬운 설명
해커가 조작된 요청을 보내면 서버가 내부적으로 몰래 다른 곳에 추가적인 요청을 보내게 만드는 보안 약점입니다. 이를 통해 내부 시스템의 정보를 알아내거나 비정상적인 동작을 유도할 수 있습니다.
🇺🇸 원문 (English)
Applications using Spring Cloud Gateway are vulnerable to specifically crafted requests that could make an extra request on downstream services. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.5+, 2.2.x users should upgrade to 2.2.10.RELEASE or newer.
📍 영향받는 시스템
Spring Cloud Gateway 3.0.x 미만 버전 및 2.2.x 미만 버전
⚔️ 공격 벡터
특수하게 조작된 HTTP 요청을 게이트웨이로 전송
🛡️ 대응 방법
3.0.x 사용자는 3.0.5 이상으로, 2.2.x 사용자는 2.2.10.RELEASE 이상으로 업그레이드
🔧 검증 코드
출력된 결과에서 spring-cloud-gateway의 버전을 확인하여 취약 버전인지 체크합니다.
mvn dependency:tree | grep spring-cloud-gateway