🔍 CVE-2021-39138

4.8
CVSS Score
MEDIUM
2021-08-19
2026-06-17 04:03
✅ 완료

🇰🇷 한글 설명

Parse Server 4.5.1 미만 버전에서 익명 사용자가 REST API를 통해 처음 가입할 때 세션 생성 오류가 발생합니다. 이로 인해 _Session 클래스의 createdWith 필드 내 authProvider가 익명 사용자를 비밀번호 기반 사용자로 잘못 표시할 수 있습니다. 개발자가 이 필드를 기반으로 권한을 구분할 경우 보안 취약점이 발생할 수 있습니다.

💡 쉬운 설명

익명으로 가입한 사용자가 시스템상에서는 마치 비밀번호를 설정한 일반 사용자인 것처럼 잘못 표시되는 문제입니다. 만약 관리자가 이 표시를 보고 권한을 다르게 부여한다면 보안 문제가 생길 수 있습니다.

🇺🇸 원문 (English)

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Developers can use the REST API to signup users and also allow users to login anonymously. Prior to version 4.5.1, when an anonymous user is first signed up using REST, the server creates session incorrectly. Particularly, the `authProvider` field in `_Session` class under `createdWith` shows the user logged in creating a password. If a developer later depends on the `createdWith` field to provide a different level of access between a password user and anonymous user, the server incorrectly classified the session type as being created with a `password`. The server does not currently use `createdWith` to make decisions about internal functions, so if a developer is not using `createdWith` directly, they are not affected. The vulnerability only affects users who depend on `createdWith` by using it directly. The issue is patched in Parse Server version 4.5.1. As a workaround, do not use the `createdWith` Session field to make decisions if one allows anonymous login.

📍 영향받는 시스템

Parse Server 4.5.1 미만 버전

⚔️ 공격 벡터

익명 가입 기능을 통해 세션 정보를 조작하거나 잘못된 권한을 획득하는 방식

🛡️ 대응 방법

Parse Server를 4.5.1 이상 버전으로 업데이트하거나, 권한 결정 시 createdWith 필드를 사용하지 않도록 수정

🔧 검증 코드

출력된 결과에서 parse-server의 버전이 4.5.1 미만인지 확인

Shell / Script
npm list parse-server

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

💻 영향받는 소프트웨어

Node.js