🔍 CVE-2021-41188

5.7
CVSS Score
MEDIUM
2021-10-26
2026-06-17 04:08
✅ 완료

🇰🇷 한글 설명

Shopware 오픈 소스 이커머스 소프트웨어 5.7.6 미만 버전에서 교차 사이트 스크립팅(XSS) 취약점이 발견되었습니다. 이 문제는 5.7.6 버전에서 패치되었으며, 보안 플러그인 사용이나 .htaccess 또는 nginx 설정을 통해 완화할 수 있습니다.

💡 쉬운 설명

웹사이트에 악성 코드를 삽입하여 사용자의 정보를 훔칠 수 있는 보안 약점이 발견되었습니다. 소프트웨어를 최신 버전으로 업데이트하거나 보안 설정을 추가하여 방어해야 합니다.

🇺🇸 원문 (English)

Shopware is open source e-commerce software. Versions prior to 5.7.6 contain a cross-site scripting vulnerability. This issue is patched in version 5.7.6. Two workarounds are available. Using the security plugin or adding a particular following config to the `.htaccess` file will protect against cross-site scripting in this case. There is also a config for those using nginx as a server. The plugin and the configs can be found on the GitHub Security Advisory page for this vulnerability.

📍 영향받는 시스템

Shopware 5.7.6 미만 모든 버전

⚔️ 공격 벡터

악성 스크립트가 포함된 요청을 웹 애플리케이션에 전송하여 사용자 브라우저에서 실행되도록 유도

🛡️ 대응 방법

Shopware를 5.7.6 이상 버전으로 업데이트하거나 보안 플러그인 및 서버 설정(.htaccess/nginx) 적용

🔧 검증 코드

명령어 결과에 취약한 버전 범위가 나타나면 해당 버전이 설치되어 있음을 의미합니다.

Shell / Script
php bin/console --version | grep -E 'Shopware (5\.[0-5]\.[0-5]|5\.6\.[0-5]|5\.7\.[0-5])'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N

💻 영향받는 소프트웨어

Nginx