🇰🇷 한글 설명
Flatpak의 메타데이터 처리 과정에서 널 바이트(null byte)를 적절히 검증하지 못하는 취약점이 발견되었습니다. 공격자가 메타데이터 파일에 널 바이트를 삽입하면, 사용자에게 표시되는 권한과 실제 실행 시 부여되는 권한을 다르게 설정하여 사용자 몰래 권한을 탈취할 수 있습니다.
💡 쉬운 설명
앱을 설치할 때 보여주는 권한 목록과 실제로 앱이 사용하는 권한이 다를 수 있는 보안 결함입니다. 나쁜 의도를 가진 앱이 사용자에게는 안전해 보이게 속인 뒤, 뒤에서 몰래 시스템 권한을 가져갈 수 있습니다.
🇺🇸 원문 (English)
Flatpak is a Linux application sandboxing and distribution framework. Prior to versions 1.12.3 and 1.10.6, Flatpak doesn't properly validate that the permissions displayed to the user for an app at install time match the actual permissions granted to the app at runtime, in the case that there's a null byte in the metadata file of an app. Therefore apps can grant themselves permissions without the consent of the user. Flatpak shows permissions to the user during install by reading them from the "xa.metadata" key in the commit metadata. This cannot contain a null terminator, because it is an untrusted GVariant. Flatpak compares these permissions to the *actual* metadata, from the "metadata" file to ensure it wasn't lied to. However, the actual metadata contents are loaded in several places where they are read as simple C-style strings. That means that, if the metadata file includes a null terminator, only the content of the file from *before* the terminator gets compared to xa.metadata. Thus, any permissions that appear in the metadata file after a null terminator are applied at runtime but not shown to the user. So maliciously crafted apps can give themselves hidden permissions. Users who have Flatpaks installed from untrusted sources are at risk in case the Flatpak has a maliciously crafted metadata file, either initially or in an update. This issue is patched in versions 1.12.3 and 1.10.6. As a workaround, users can manually check the permissions of installed apps by checking the metadata file or the xa.metadata key on the commit metadata.
📍 영향받는 시스템
Flatpak versions prior to 1.12.3 and 1.10.6
⚔️ 공격 벡터
악성 메타데이터가 포함된 Flatpak 앱 또는 업데이트를 통한 권한 탈취
🛡️ 대응 방법
Flatpak을 1.12.3 또는 1.10.6 이상의 최신 버전으로 업데이트하십시오.
🔧 검증 코드
출력된 버전이 1.12.3 또는 1.10.6보다 낮은지 확인하여 취약 여부를 판단합니다.
📊 CVSS Vector String
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
💻 영향받는 소프트웨어
NVIDIA vGPU Guest Driver for Linux