🔍 CVE-2022-1434

5.9
CVSS Score
MEDIUM
2022-05-03
2026-10-14 13:17
✅ 완료

🇰🇷 한글 설명

OpenSSL 3.0의 RC4-MD5 암호화 스위트 구현에서 AAD 데이터를 MAC 키로 잘못 사용하는 취약점이 발견되었습니다. 이로 인해 공격자가 중간자 공격(MitM)을 통해 데이터의 무결성 검사를 통과하도록 데이터를 변조할 수 있습니다. 다만, 이 취약점은 취약한 암호화 설정이 명시적으로 활성화된 특수한 환경에서만 발생합니다.

💡 쉬운 설명

데이터가 전송 중에 누군가에 의해 몰래 수정되어도 시스템이 이를 알아채지 못할 수 있는 보안 결함입니다. 하지만 일반적인 최신 보안 설정에서는 이 기능이 꺼져 있어 공격이 매우 어렵습니다.

🇺🇸 원문 (English)

The OpenSSL 3.0 implementation of the RC4-MD5 ciphersuite incorrectly uses the AAD data as the MAC key. This makes the MAC key trivially predictable. An attacker could exploit this issue by performing a man-in-the-middle attack to modify data being sent from one endpoint to an OpenSSL 3.0 recipient such that the modified data would still pass the MAC integrity check. Note that data sent from an OpenSSL 3.0 endpoint to a non-OpenSSL 3.0 endpoint will always be rejected by the recipient and the connection will fail at that point. Many application protocols require data to be sent from the client to the server first. Therefore, in such a case, only an OpenSSL 3.0 server would be impacted when talking to a non-OpenSSL 3.0 client. If both endpoints are OpenSSL 3.0 then the attacker could modify data being sent in both directions. In this case both clients and servers could be affected, regardless of the application protocol. Note that in the absence of an attacker this bug means that an OpenSSL 3.0 endpoint communicating with a non-OpenSSL 3.0 endpoint will fail to complete the handshake when using this ciphersuite. The confidentiality of data is not impacted by this issue, i.e. an attacker cannot decrypt data that has been encrypted using this ciphersuite - they can only modify it. In order for this attack to work both endpoints must legitimately negotiate the RC4-MD5 ciphersuite. This ciphersuite is not compiled by default in OpenSSL 3.0, and is not available within the default provider or the default ciphersuite list. This ciphersuite will never be used if TLSv1.3 has been negotiated. In order for an OpenSSL 3.0 endpoint to use this ciphersuite the following must have occurred: 1) OpenSSL must have been compiled with the (non-default) compile time option enable-weak-ssl-ciphers 2) OpenSSL must have had the legacy provider explicitly loaded (either through application code or via configuration) 3) The ciphersuite must have been explicitly added to the ciphersuite list 4) The libssl security level must have been set to 0 (default is 1) 5) A version of SSL/TLS below TLSv1.3 must have been negotiated 6) Both endpoints must negotiate the RC4-MD5 ciphersuite in preference to any others that both endpoints have in common Fixed in OpenSSL 3.0.3 (Affected 3.0.0,3.0.1,3.0.2).

📍 영향받는 시스템

OpenSSL 3.0.0, 3.0.1, 3.0.2 버전

⚔️ 공격 벡터

중간자 공격(Man-in-the-Middle)을 통한 데이터 변조

🛡️ 대응 방법

OpenSSL 3.0.3 이상 버전으로 업데이트

🔧 검증 코드

출력된 버전이 3.0.3 미만인지 확인하여 취약 여부를 판단합니다.

Shell / Script
openssl version

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

💻 영향받는 소프트웨어

OpenSSL