🔍 CVE-2022-24736

3.3
CVSS Score
LOW
2022-04-27
2026-06-17 04:32
✅ 완료

🇰🇷 한글 설명

Redis 6.2.7 및 7.0.0 미만 버전에서 특수하게 제작된 Lua 스크립트를 로드할 경우 NULL 포인터 역참조가 발생하여 redis-server 프로세스가 충돌할 수 있습니다. 이 취약점은 Redis 7.0.0 및 6.2.7 버전에서 수정되었습니다.

💡 쉬운 설명

해커가 조작된 명령어를 보내면 Redis 데이터베이스 프로그램이 갑자기 꺼져버릴 수 있는 문제입니다. 이로 인해 서비스가 중단되는 현상이 발생할 수 있습니다.

🇺🇸 원문 (English)

Redis is an in-memory database that persists on disk. Prior to versions 6.2.7 and 7.0.0, an attacker attempting to load a specially crafted Lua script can cause NULL pointer dereference which will result with a crash of the redis-server process. The problem is fixed in Redis versions 7.0.0 and 6.2.7. An additional workaround to mitigate this problem without patching the redis-server executable, if Lua scripting is not being used, is to block access to `SCRIPT LOAD` and `EVAL` commands using ACL rules.

📍 영향받는 시스템

Redis versions prior to 6.2.7 and 7.0.0

⚔️ 공격 벡터

특수하게 제작된 Lua 스크립트를 로드하는 공격

🛡️ 대응 방법

Redis를 6.2.7 또는 7.0.0 이상의 버전으로 업데이트하거나, ACL 규칙을 통해 SCRIPT LOAD 및 EVAL 명령어를 차단합니다.

🔧 검증 코드

출력된 버전이 6.2.7 미만이거나 7.0.0 미만인 경우 취약한 버전이 설치된 것입니다.

Shell / Script
redis-server --version | grep -E 'redis-server v(6\.[0-6]\.|[0-6]\.[0-7]\.)'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

💻 영향받는 소프트웨어

Redis