🇰🇷 한글 설명
OpenSSL 3.0.0에서 3.0.5 버전 사이에서 발생하는 취약점으로, 사용자 정의 암호화 방식을 설정할 때 NID_undef 값을 잘못 전달하면 발생합니다. 이 경우 시스템이 암호화 대신 NULL 암호(암호화되지 않은 상태)를 사용하여 평문이 그대로 노출될 수 있습니다.
💡 쉬운 설명
암호화 기능을 사용할 때 실수로 '암호화하지 마라'는 명령이 실행되어 데이터가 암호화되지 않은 채 그대로 전송될 수 있는 문제입니다. 보안이 적용되어야 할 데이터가 아무런 보호 없이 노출될 위험이 있습니다.
🇺🇸 원문 (English)
OpenSSL supports creating a custom cipher via the legacy EVP_CIPHER_meth_new() function and associated function calls. This function was deprecated in OpenSSL 3.0 and application authors are instead encouraged to use the new provider mechanism in order to implement custom ciphers. OpenSSL versions 3.0.0 to 3.0.5 incorrectly handle legacy custom ciphers passed to the EVP_EncryptInit_ex2(), EVP_DecryptInit_ex2() and EVP_CipherInit_ex2() functions (as well as other similarly named encryption and decryption initialisation functions). Instead of using the custom cipher directly it incorrectly tries to fetch an equivalent cipher from the available providers. An equivalent cipher is found based on the NID passed to EVP_CIPHER_meth_new(). This NID is supposed to represent the unique NID for a given cipher. However it is possible for an application to incorrectly pass NID_undef as this value in the call to EVP_CIPHER_meth_new(). When NID_undef is used in this way the OpenSSL encryption/decryption initialisation function will match the NULL cipher as being equivalent and will fetch this from the available providers. This will succeed if the default provider has been loaded (or if a third party provider has been loaded that offers this cipher). Using the NULL cipher means that the plaintext is emitted as the ciphertext. Applications are only affected by this issue if they call EVP_CIPHER_meth_new() using NID_undef and subsequently use it in a call to an encryption/decryption initialisation function. Applications that only use SSL/TLS are not impacted by this issue. Fixed in OpenSSL 3.0.6 (Affected 3.0.0-3.0.5).
📍 영향받는 시스템
OpenSSL 3.0.0 ~ 3.0.5 버전
⚔️ 공격 벡터
애플리케이션이 EVP_CIPHER_meth_new() 함수 호출 시 NID_undef를 사용하여 잘못된 암호화 방식을 초기화할 때 발생
🛡️ 대응 방법
OpenSSL 버전을 3.0.6 이상으로 업데이트
🔧 검증 코드
출력된 버전이 3.0.6 미만(3.0.0~3.0.5)인 경우 해당 취약점에 노출된 상태입니다.