🔍 CVE-2022-33684

8.1
CVSS Score
HIGH
2022-11-04
2026-06-17 04:49
✅ 완료

🇰🇷 한글 설명

Apache Pulsar C++ 및 Python 클라이언트가 OAuth2.0 Client Credential Flow를 사용할 때 HTTPS 호출 시 TLS 인증서를 검증하지 않는 취약점입니다. 이로 인해 공격자가 중간자 공격(MitM)을 수행하여 인증 정보를 가로채거나 수정할 수 있습니다. 공격자가 클라이언트와 서버 사이의 네트워크를 제어할 수 있는 환경에서 발생합니다.

💡 쉬운 설명

인터넷 연결 시 상대방이 진짜인지 확인하는 보안 절차가 빠져 있어, 해커가 중간에서 정보를 훔쳐볼 수 있는 상태입니다. 해커가 가짜 서버를 내세워 사용자의 로그인 정보를 가로챌 위험이 있습니다.

🇺🇸 원문 (English)

The Apache Pulsar C++ Client does not verify peer TLS certificates when making HTTPS calls for the OAuth2.0 Client Credential Flow, even when tlsAllowInsecureConnection is disabled via configuration. This vulnerability allows an attacker to perform a man in the middle attack and intercept and/or modify the GET request that is sent to the ClientCredentialFlow 'issuer url'. The intercepted credentials can be used to acquire authentication data from the OAuth2.0 server to then authenticate with an Apache Pulsar cluster. An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack. The Apache Pulsar Python Client wraps the C++ client, so it is also vulnerable in the same way. This issue affects Apache Pulsar C++ Client and Python Client versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.3; 2.9.0 to 2.9.2; 2.10.0 to 2.10.1; 2.6.4 and earlier. Any users running affected versions of the C++ Client or the Python Client should rotate vulnerable OAuth2.0 credentials, including client_id and client_secret. 2.7 C++ and Python Client users should upgrade to 2.7.5 and rotate vulnerable OAuth2.0 credentials. 2.8 C++ and Python Client users should upgrade to 2.8.4 and rotate vulnerable OAuth2.0 credentials. 2.9 C++ and Python Client users should upgrade to 2.9.3 and rotate vulnerable OAuth2.0 credentials. 2.10 C++ and Python Client users should upgrade to 2.10.2 and rotate vulnerable OAuth2.0 credentials. 3.0 C++ users are unaffected and 3.0 Python Client users will be unaffected when it is released. Any users running the C++ and Python Client for 2.6 or less should upgrade to one of the above patched versions.

📍 영향받는 시스템

Apache Pulsar C++ 및 Python Client (2.6.4 이하, 2.7.0-2.7.4, 2.8.0-2.8.3, 2.9.0-2.9.2, 2.10.0-2.10.1)

⚔️ 공격 벡터

클라이언트와 서버 사이의 네트워크를 장악한 공격자가 중간자 공격(Man-in-the-Middle)을 통해 TLS 인증서 검증 없이 트래픽을 가로챔

🛡️ 대응 방법

패치된 버전(2.7.5, 2.8.4, 2.9.3, 2.10.2 이상)으로 업그레이드하고 기존 OAuth2.0 자격 증명(client_id, client_secret)을 교체함

🔧 검증 코드

출력된 버전 번호가 취약한 버전 범위에 포함되는지 확인합니다.

Shell / Script
pip show pulsar-client | grep Version || python3 -c 'import pulsar; print(pulsar.__version__)'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Apache HTTP Server