🔍 CVE-2022-34321

8.2
CVSS Score
HIGH
2024-03-12
2026-06-17 04:50
✅ 완료

🇰🇷 한글 설명

Apache Pulsar Proxy에서 인증 없이 /proxy-stats 엔드포인트에 접근할 수 있는 부적절한 인증 취약점이 발견되었습니다. 공격자는 이를 통해 연결된 클라이언트 IP와 같은 민감한 정보를 노출시키거나, 로깅 수준을 임의로 변경하여 서비스 거부(DoS) 상태를 유발할 수 있습니다.

💡 쉬운 설명

로그인 없이도 서버의 상세한 연결 정보를 훔쳐보거나 서버 설정을 마음대로 바꿀 수 있는 보안 구멍이 발견되었습니다. 공격자가 로그 기록을 과도하게 늘리도록 설정하면 서버가 느려지거나 멈출 수 있습니다.

🇺🇸 원문 (English)

Improper Authentication vulnerability in Apache Pulsar Proxy allows an attacker to connect to the /proxy-stats endpoint without authentication. The vulnerable endpoint exposes detailed statistics about live connections, along with the capability to modify the logging level of proxied connections without requiring proper authentication credentials. This issue affects Apache Pulsar versions from 2.6.0 to 2.10.5, from 2.11.0 to 2.11.2, from 3.0.0 to 3.0.1, and 3.1.0. The known risks include exposing sensitive information such as connected client IP and unauthorized logging level manipulation which could lead to a denial-of-service condition by significantly increasing the proxy's logging overhead. When deployed via the Apache Pulsar Helm chart within Kubernetes environments, the actual client IP might not be revealed through the load balancer's default behavior, which typically obscures the original source IP addresses when externalTrafficPolicy is being configured to "Cluster" by default. The /proxy-stats endpoint contains topic level statistics, however, in the default configuration, the topic level statistics aren't known to be exposed. 2.10 Pulsar Proxy users should upgrade to at least 2.10.6. 2.11 Pulsar Proxy users should upgrade to at least 2.11.3. 3.0 Pulsar Proxy users should upgrade to at least 3.0.2. 3.1 Pulsar Proxy users should upgrade to at least 3.1.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions. Additionally, it's imperative to recognize that the Apache Pulsar Proxy is not intended for direct exposure to the internet. The architectural design of Pulsar Proxy assumes that it will operate within a secured network environment, safeguarded by appropriate perimeter defenses.

📍 영향받는 시스템

Apache Pulsar 2.6.0-2.10.5, 2.11.0-2.11.2, 3.0.0-3.0.1, 3.1.0

⚔️ 공격 벡터

인증 없이 /proxy-stats 엔드포인트에 HTTP 요청을 보내 정보 탈취 및 로깅 설정 조작

🛡️ 대응 방법

Pulsar Proxy를 2.10.6, 2.11.3, 3.0.2, 3.1.1 이상의 패치된 버전으로 업그레이드

🔧 검증 코드

설치된 Apache Pulsar의 버전을 확인하여 취약한 버전 범위에 해당하는지 대조합니다.

Shell / Script
pulsar-admin cluster list 2>/dev/null | grep -i 'pulsar' && pulsar-admin --version

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L

💻 영향받는 소프트웨어

Spring for Apache Pulsar