🔍 CVE-2022-35925

5.3
CVSS Score
MEDIUM
2022-08-02
2026-06-17 04:52
✅ 완료

🇰🇷 한글 설명

독서 기록 소셜 네트워크인 BookWyrm의 0.4.5 미만 버전에서 인증 뷰에 대한 속도 제한(rate limiting)이 누락된 취약점이 발견되었습니다. 이로 인해 공격자가 무차별 대입 공격(brute-force attack)을 수행할 수 있습니다. 해당 문제는 0.4.5 버전에서 패치되었습니다.

💡 쉬운 설명

로그인 시도 횟수를 제한하는 기능이 없어, 해커가 비밀번호를 맞출 때까지 계속해서 로그인을 시도할 수 있는 문제입니다. 이를 방지하기 위해 시스템을 업데이트하거나 보안 설정을 변경해야 합니다.

🇺🇸 원문 (English)

BookWyrm is a social network for tracking reading. Versions prior to 0.4.5 were found to lack rate limiting on authentication views which allows brute-force attacks. This issue has been patched in version 0.4.5. Admins with existing instances will need to update their `nginx.conf` file that was created when the instance was set up. Users are advised advised to upgrade. Users unable to upgrade may update their nginx.conf files with the changes manually.

📍 영향받는 시스템

BookWyrm 0.4.5 미만 모든 버전

⚔️ 공격 벡터

인증 페이지에 대한 무차별 대입 공격(Brute-force attack)

🛡️ 대응 방법

BookWyrm을 0.4.5 버전 이상으로 업그레이드하거나, nginx.conf 파일을 수동으로 업데이트하여 속도 제한을 설정하십시오.

🔧 검증 코드

출력된 버전 번호가 0.4.5 미만이면 취약한 상태입니다.

Shell / Script
python3 -c 'import bookwyrm; print(bookwyrm.__version__)' 2>/dev/null || echo 'Version check failed'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

💻 영향받는 소프트웨어

Nginx