🔍 CVE-2022-46792

8.8
CVSS Score
HIGH
2022-12-08
2026-06-17 05:12
✅ 완료

🇰🇷 한글 설명

Hasura GraphQL Engine 2.15.2 미만 버전에서 Postgres 백엔드의 Update Many API 사용 시 행 수준 권한 부여(Row-level authorization)를 잘못 처리하는 취약점이 발견되었습니다. 이로 인해 권한이 없는 사용자가 데이터를 수정할 수 있는 위험이 있습니다.

💡 쉬운 설명

데이터를 수정할 때 '자신에게 허용된 데이터만 고칠 수 있게' 막아주는 보안 장치가 제대로 작동하지 않는 문제입니다. 공격자가 다른 사용자의 정보를 마음대로 수정할 수 있는 위험이 있습니다.

🇺🇸 원문 (English)

Hasura GraphQL Engine before 2.15.2 mishandles row-level authorization in the Update Many API for Postgres backends. The fixed versions are 2.10.2, 2.11.3, 2.12.1, 2.13.2, 2.14.1, and 2.15.2. (Versions before 2.10.0 are unaffected.)

📍 영향받는 시스템

Hasura GraphQL Engine 2.10.0 이상 2.15.2 미만 버전 (Postgres 백엔드 사용 시)

⚔️ 공격 벡터

Update Many API를 호출하여 권한 검증을 우회하고 승인되지 않은 행(row)을 수정

🛡️ 대응 방법

Hasura GraphQL Engine을 수정된 버전(2.10.2, 2.11.3, 2.12.1, 2.13.2, 2.14.1, 2.15.2 이상)으로 업데이트

🔧 검증 코드

명령어 결과에 취약한 버전 범위가 출력되면 업데이트가 필요한 상태입니다.

Shell / Script
hasura version | grep -E '2\.(10\.[2-9]|11\.[3-9]|12\.[1-9]|13\.[2-9]|14\.[1-9]|15\.[0-1])'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Spring for GraphQL