🔍 CVE-2023-25173

5.3
CVSS Score
MEDIUM
2023-02-16
2026-06-17 05:40
✅ 완료

🇰🇷 한글 설명

containerd 1.6.18 및 1.5.18 미만 버전에서 컨테이너 내부의 보조 그룹(supplementary groups)이 적절하게 설정되지 않는 취약점이 발견되었습니다. 공격자가 컨테이너에 직접 접근할 수 있는 경우, 보조 그룹 권한을 조작하여 기본 그룹 제한을 우회하고 민감한 정보에 접근하거나 코드를 실행할 수 있습니다.

💡 쉬운 설명

컨테이너 안에서 사용자의 권한을 나누는 규칙이 제대로 적용되지 않는 버그가 있습니다. 이를 통해 공격자가 원래는 접근할 수 없는 파일이나 기능을 몰래 사용할 위험이 있습니다.

🇺🇸 원문 (English)

containerd is an open source container runtime. A bug was found in containerd prior to versions 1.6.18 and 1.5.18 where supplementary groups are not set up properly inside a container. If an attacker has direct access to a container and manipulates their supplementary group access, they may be able to use supplementary group access to bypass primary group restrictions in some cases, potentially gaining access to sensitive information or gaining the ability to execute code in that container. Downstream applications that use the containerd client library may be affected as well. This bug has been fixed in containerd v1.6.18 and v.1.5.18. Users should update to these versions and recreate containers to resolve this issue. Users who rely on a downstream application that uses containerd's client library should check that application for a separate advisory and instructions. As a workaround, ensure that the `"USER $USERNAME"` Dockerfile instruction is not used. Instead, set the container entrypoint to a value similar to `ENTRYPOINT ["su", "-", "user"]` to allow `su` to properly set up supplementary groups.

📍 영향받는 시스템

containerd v1.6.18 및 v1.5.18 미만 버전 (해당 라이브러리를 사용하는 다운스트림 애플리케이션 포함)

⚔️ 공격 벡터

컨테이너에 직접 접근 권한을 가진 공격자가 보조 그룹 설정을 조작하여 그룹 제한을 우회함

🛡️ 대응 방법

containerd를 v1.6.18 또는 v1.5.18 이상으로 업데이트하고 컨테이너를 재생성하며, Dockerfile에서 'USER' 대신 'ENTRYPOINT ["su", "-", "user"]' 방식을 사용함

🔧 검증 코드

명령어 결과에 1.6.18 또는 1.5.18 이상의 버전이 표시되면 취약점이 해결된 상태입니다.

Shell / Script
containerd --version | grep -E '1.6.18|1.5.18'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

💻 영향받는 소프트웨어

Docker