🔍 CVE-2023-25661

6.5
CVSS Score
MEDIUM
2023-03-27
2026-06-17 05:41
✅ 완료

🇰🇷 한글 설명

TensorFlow 2.11.1 미만 버전에서 악의적인 입력값이 전달될 경우 모델이 충돌(Check Failed)하며 서비스 거부(DoS) 공격이 발생할 수 있습니다. 특히 현대 신경망에서 자주 사용되는 Convolution3DTranspose 함수를 통해 공격이 가능합니다.

💡 쉬운 설명

머신러닝 모델에 잘못된 데이터를 입력하여 프로그램이 갑자기 멈추게 만드는 공격입니다. 이를 통해 클라우드 서비스나 AI 애플리케이션의 운영을 방해할 수 있습니다.

🇺🇸 원문 (English)

TensorFlow is an Open Source Machine Learning Framework. In versions prior to 2.11.1 a malicious invalid input crashes a tensorflow model (Check Failed) and can be used to trigger a denial of service attack. A proof of concept can be constructed with the `Convolution3DTranspose` function. This Convolution3DTranspose layer is a very common API in modern neural networks. The ML models containing such vulnerable components could be deployed in ML applications or as cloud services. This failure could be potentially used to trigger a denial of service attack on ML cloud services. An attacker must have privilege to provide input to a `Convolution3DTranspose` call. This issue has been patched and users are advised to upgrade to version 2.11.1. There are no known workarounds for this vulnerability.

📍 영향받는 시스템

TensorFlow 2.11.1 미만 모든 버전

⚔️ 공격 벡터

Convolution3DTranspose 함수에 조작된 입력값을 전달하여 모델 프로세스를 강제 종료

🛡️ 대응 방법

TensorFlow를 2.11.1 이상 버전으로 업그레이드

🔧 검증 코드

출력된 버전 번호가 2.11.1보다 낮은지 확인

Shell / Script
python3 -c 'import tensorflow as tf; print(tf.__version__)'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

Cloud Services