🔍 CVE-2023-28110

5.7
CVSS Score
MEDIUM
2023-03-16
2026-06-17 05:46
✅ 완료

🇰🇷 한글 설명

Jumpserver의 구성 요소인 Koko에서 발생하는 취약점으로, 2.28.8 버전 이전에서는 Kubernetes 클러스터 연결 시 잘못된 토큰을 사용하면 위험한 명령어가 실행될 수 있습니다. 이로 인해 Koko 컨테이너 환경이 중단되거나 정상적인 서비스 이용에 영향을 받을 수 있습니다.

💡 쉬운 설명

Koko라는 시스템에 가짜 인증 정보를 보내면 공격자가 시스템에 나쁜 명령을 내릴 수 있는 문제입니다. 이로 인해 서비스가 멈추거나 제대로 작동하지 않을 수 있습니다.

🇺🇸 원문 (English)

Jumpserver is a popular open source bastion host, and Koko is a Jumpserver component that is the Go version of coco, refactoring coco's SSH/SFTP service and Web Terminal service. Prior to version 2.28.8, using illegal tokens to connect to a Kubernetes cluster through Koko can result in the execution of dangerous commands that may disrupt the Koko container environment and affect normal usage. The vulnerability has been fixed in v2.28.8.

📍 영향받는 시스템

Jumpserver Koko 버전 2.28.8 미만

⚔️ 공격 벡터

Kubernetes 클러스터 연결 시 조작된(illegal) 토큰을 전송하여 명령 실행

🛡️ 대응 방법

Jumpserver Koko를 v2.28.8 이상 버전으로 업데이트

🔧 검증 코드

출력된 버전 정보가 2.28.8보다 낮은지 확인하여 취약 여부를 판단합니다.

Shell / Script
docker exec <koko_container_id> cat /app/version 2>/dev/null || echo 'Version check failed'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H

💻 영향받는 소프트웨어

Kubernetes