🔍 CVE-2023-28665

5.4
CVSS Score
MEDIUM
2023-03-22
2026-10-23 23:10
✅ 완료

🇰🇷 한글 설명

Woo Bulk Price Update WordPress 플러그인 2.2.2 미만 버전에는 techno_get_products 액션의 'page' 파라미터에서 발생하는 반사형 크로스 사이트 스크립팅(XSS) 취약점이 존재합니다. 이 취약점은 인증된 사용자만 악용할 수 있습니다.

💡 쉬운 설명

워드프레스 쇼핑몰의 가격 일괄 변경 플러그인에 있는 보안 결함입니다. 로그인한 사용자가 악성 링크를 클릭하면 공격자가 설정한 스크립트가 실행될 수 있습니다.

🇺🇸 원문 (English)

The Woo Bulk Price Update WordPress plugin, in versions < 2.2.2, is affected by a reflected cross-site scripting vulnerability in the 'page' parameter to the techno_get_products action, which can only be triggered by an authenticated user.

📍 영향받는 시스템

Woo Bulk Price Update 플러그인 2.2.2 미만 버전이 설치된 WordPress 사이트

⚔️ 공격 벡터

공격자가 'page' 파라미터에 악성 스크립트를 삽입한 링크를 인증된 사용자가 클릭하도록 유도하여 브라우저에서 스크립트를 실행

🛡️ 대응 방법

Woo Bulk Price Update 플러그인을 2.2.2 이상 버전으로 업데이트하고, 사용하지 않는 경우 비활성화 또는 삭제

🔧 검증 코드

출력된 버전 값이 2.2.2 미만이면 취약하며, 2.2.2 이상이면 패치가 적용된 상태입니다. 결과가 없으면 플러그인 경로를 직접 확인해야 합니다.

Shell / Script
grep -i 'Version' $(find /var/www -path '*woo-bulk-price*' -name '*.php' 2>/dev/null | head -1) 2>/dev/null | head -1

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

💻 영향받는 소프트웨어

WordPress