🔍 CVE-2023-30428

8.2
CVSS Score
HIGH
2023-07-12
2026-06-17 05:54
✅ 완료

🇰🇷 한글 설명

Apache Pulsar Broker의 Rest Producer에서 발생하는 권한 부여 오류 취약점입니다. 인증된 사용자가 특정 HTTP 헤더를 사용하여 브로커의 관리자 권한으로 모든 토픽에 메시지를 전송할 수 있습니다. 이로 인해 임의의 메시지 삽입이나 토픽 정책 변경을 통한 데이터 유출 및 삭제 위험이 발생합니다.

💡 쉬운 설명

로그인한 사용자가 관리자 권한을 몰래 흉내 내어 시스템의 모든 메시지 통로에 가짜 데이터를 넣거나 설정을 바꿀 수 있는 문제입니다. 이를 통해 중요한 정보를 빼가거나 데이터를 삭제할 위험이 있습니다.

🇺🇸 원문 (English)

Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar Broker's Rest Producer allows authenticated user with a custom HTTP header to produce a message to any topic using the broker's admin role. This issue affects Apache Pulsar Brokers: from 2.9.0 through 2.9.5, from 2.10.0 before 2.10.4, 2.11.0. The vulnerability is exploitable when an attacker can connect directly to the Pulsar Broker. If an attacker is connecting through the Pulsar Proxy, there is no known way to exploit this authorization vulnerability. There are two known risks for affected users. First, an attacker could produce garbage messages to any topic in the cluster. Second, an attacker could produce messages to the topic level policies topic for other tenants and influence topic settings that could lead to exfiltration and/or deletion of messages for other tenants. 2.8 Pulsar Broker users and earlier are unaffected. 2.9 Pulsar Broker users should upgrade to one of the patched versions. 2.10 Pulsar Broker users should upgrade to at least 2.10.4. 2.11 Pulsar Broker users should upgrade to at least 2.11.1. 3.0 Pulsar Broker users are unaffected.

📍 영향받는 시스템

Apache Pulsar Broker 2.9.0-2.9.5, 2.10.0-2.10.3, 2.11.0

⚔️ 공격 벡터

브로커에 직접 연결 가능한 인증된 사용자가 커스텀 HTTP 헤더를 사용하여 관리자 권한으로 메시지 생성

🛡️ 대응 방법

Apache Pulsar를 2.9.6, 2.10.4 또는 2.11.1 이상의 패치된 버전으로 업그레이드

🔧 검증 코드

출력된 버전 번호가 취약한 버전 범위(2.9.0-2.9.5, 2.10.0-2.10.3, 2.11.0)에 포함되는지 확인

Shell / Script
pulsar-admin --version 2>/dev/null || echo 'Pulsar not found'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N

💻 영향받는 소프트웨어

Spring for Apache Pulsar