🔍 CVE-2023-37273

8.1
CVSS Score
HIGH
2023-07-13
2026-06-17 06:07
✅ 완료

🇰🇷 한글 설명

Auto-GPT 0.4.3 미만 버전에서 docker-compose.yml 파일이 쓰기 권한이 있는 상태로 컨테이너에 마운트되는 취약점이 발견되었습니다. 공격자가 파이썬 코드 실행 기능을 통해 이 파일을 변조하면, 다음 실행 시 호스트 시스템의 제어권을 탈취할 수 있습니다.

💡 쉬운 설명

프로그램이 설정 파일을 수정할 수 있는 권한을 잘못 가지고 있어, 나쁜 코드가 실행되면 컴퓨터 전체를 해킹할 수 있는 상태입니다. 해커가 설정 파일을 바꿔치기하여 다음번에 프로그램이 켜질 때 몰래 명령을 내릴 수 있습니다.

🇺🇸 원문 (English)

Auto-GPT is an experimental open-source application showcasing the capabilities of the GPT-4 language model. Running Auto-GPT version prior to 0.4.3 by cloning the git repo and executing `docker compose run auto-gpt` in the repo root uses a different docker-compose.yml file from the one suggested in the official docker set up instructions. The docker-compose.yml file located in the repo root mounts itself into the docker container without write protection. This means that if malicious custom python code is executed via the `execute_python_file` and `execute_python_code` commands, it can overwrite the docker-compose.yml file and abuse it to gain control of the host system the next time Auto-GPT is started. The issue has been patched in version 0.4.3.

📍 영향받는 시스템

Auto-GPT version prior to 0.4.3 (cloned via git and run via docker compose)

⚔️ 공격 벡터

execute_python_file 또는 execute_python_code 명령을 통한 docker-compose.yml 파일 변조

🛡️ 대응 방법

Auto-GPT를 버전 0.4.3 이상으로 업데이트하십시오.

🔧 검증 코드

사용 중인 Auto-GPT의 버전을 확인하여 0.4.3 미만인지 확인하십시오.

Shell / Script
docker exec auto-gpt python --version 2>/dev/null || echo 'Check Auto-GPT version via git log or docker image tag'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L

💻 영향받는 소프트웨어

Docker