🇰🇷 한글 설명
Apache Traffic Server에서 잘못된 형식의 HTTP/2 프레임을 처리할 때 발생하는 입력값 검증 미흡 취약점입니다. 이 문제는 Apache Traffic Server 9.0.0 버전부터 9.2.2 버전까지 영향을 미칩니다.
💡 쉬운 설명
웹 서버가 이해할 수 없는 잘못된 형태의 데이터를 받았을 때 이를 제대로 걸러내지 못하는 문제입니다. 공격자가 특수하게 조작된 데이터를 보내 서버에 문제를 일으킬 수 있습니다.
🇺🇸 원문 (English)
Improper Input Validation vulnerability in Apache Traffic Server with malformed HTTP/2 frames.This issue affects Apache Traffic Server: from 9.0.0 through 9.2.2.
Users are recommended to upgrade to version 9.2.3, which fixes the issue.
📍 영향받는 시스템
Apache Traffic Server 9.0.0 ~ 9.2.2
⚔️ 공격 벡터
조작된 HTTP/2 프레임을 전송하여 입력값 검증 로직을 우회하는 방식
🛡️ 대응 방법
Apache Traffic Server를 취약점이 해결된 9.2.3 버전 이상으로 업그레이드하십시오.
🔧 검증 코드
출력된 버전 정보가 9.0.0에서 9.2.2 사이인지 확인하여 취약 여부를 판단합니다.
apache2-traffic-server --version 2>/dev/null || httpd -v 2>/dev/null | grep -i 'traffic server'