🔍 CVE-2023-3958

8.5
CVSS Score
HIGH
2023-08-16
2026-06-17 06:15
✅ 완료

🇰🇷 한글 설명

WordPress의 WP Remote Users Sync 플러그인 1.2.12 이하 버전에서 'notify_ping_remote' AJAX 함수를 통한 서버 측 요청 위조(SSRF) 취약점이 발견되었습니다. 인증된 구독자 권한 이상의 공격자가 웹 애플리케이션을 통해 임의의 위치로 웹 요청을 보낼 수 있으며, 이를 통해 내부 서비스의 정보를 조회하거나 수정할 수 있습니다.

💡 쉬운 설명

해커가 권한을 이용해 웹사이트 서버가 마치 자기 자신인 것처럼 속여서 내부 네트워크나 다른 사이트에 몰래 명령을 내릴 수 있는 문제입니다. 이를 통해 서버 내부의 중요한 정보를 훔쳐보거나 조작할 위험이 있습니다.

🇺🇸 원문 (English)

The WP Remote Users Sync plugin for WordPress is vulnerable to Server Side Request Forgery via the 'notify_ping_remote' AJAX function in versions up to, and including, 1.2.12. This can allow authenticated attackers with subscriber-level permissions or above to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services. This was partially patched in version 1.2.12 and fully patched in version 1.2.13.

📍 영향받는 시스템

WP Remote Users Sync plugin (버전 1.2.12 이하)

⚔️ 공격 벡터

인증된 사용자가 AJAX 함수를 악용하여 서버가 임의의 URL로 요청을 보내도록 유도

🛡️ 대응 방법

WP Remote Users Sync 플러그인을 최신 버전인 1.2.13 이상으로 업데이트

🔧 검증 코드

출력된 플러그인 목록에서 버전을 확인하여 1.2.13 미만인지 체크

Shell / Script
wp plugin list --status=active | grep 'wp-remote-users-sync'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N

💻 영향받는 소프트웨어

Spring Web Services