🔍 CVE-2023-6805

6.4
CVSS Score
MEDIUM
2024-04-17
2026-06-17 06:51
✅ 완료

🇰🇷 한글 설명

WordPress의 Feedzy RSS Aggregator 플러그인 fetch_feed 기능에서 Blind SSRF 취약점이 발견되었습니다. 기여자(Contributor) 이상의 권한을 가진 인증된 공격자가 웹 애플리케이션을 통해 임의의 위치로 웹 요청을 보낼 수 있으며, 이를 통해 내부 서비스의 정보를 수정할 수 있습니다.

💡 쉬운 설명

해커가 웹사이트의 권한을 이용해 서버가 내부 네트워크의 다른 컴퓨터에 몰래 접속하게 만드는 공격입니다. 이를 통해 외부에서는 볼 수 없는 내부 시스템의 정보를 조작하거나 훔쳐볼 수 있습니다.

🇺🇸 원문 (English)

The RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator plugin for WordPress is vulnerable to Blind Server-Side Request Forgery in all versions up to, and including, 4.4.7 via the fetch_feed functionality. This makes it possible for authenticated attackers, with contributor access and above, to make web requests to arbitrary locations originating from the web application and can be used to modify information from internal services. NOTE: This vulnerability, exploitable by contributor-level users, was was fixed in version 4.4.7. The same vulnerability was fixed for author-level users in version 4.4.8.

📍 영향받는 시스템

Feedzy RSS Aggregator 플러그인 4.4.7 이하 버전 (Author 권한은 4.4.8 이하)

⚔️ 공격 벡터

인증된 사용자(Contributor 이상)가 fetch_feed 기능을 악용하여 임의의 URL로 서버 측 요청을 유도함

🛡️ 대응 방법

플러그인을 최신 버전인 4.4.8 이상으로 업데이트하십시오.

🔧 검증 코드

명령어 결과에 Feedzy 플러그인이 나타나면, 워드프레스 관리자 페이지에서 해당 플러그인의 버전이 4.4.8 미만인지 확인하십시오.

Shell / Script
wp plugin list --status=active | grep -i 'feedzy' && echo 'Check version manually via WordPress Dashboard'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

💻 영향받는 소프트웨어

Spring Web Services