🔍 CVE-2024-11501

8.8
CVSS Score
HIGH
2024-12-07
2026-04-15 00:35
✅ 완료

🇰🇷 한글 설명

WordPress Gallery 플러그인 1.3 이하 버전에서 wd_gallery_$id 파라미터의 untrusted input을 deserialize할 때 PHP Object Injection 취약점이 발생합니다. Contributor 이상의 권한을 가진 인증된 공격자가 PHP Object를 주입할 수 있으며, 추가 플러그인이나 테마의 POP chain을 통해 파일 삭제, 민감 정보 유출, 또는 코드 실행이 가능합니다.

💡 쉬운 설명

WordPress Gallery 플러그인에 악의적인 데이터를 입력하여 서버를 제어할 수 있는 보안 결함입니다. 플러그인을 최신 버전으로 업데이트하고 다른 확장 프로그램도 함께 검사하면 안전하게 보호할 수 있습니다.

🇺🇸 원문 (English)

The Gallery plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.3 via deserialization of untrusted input from wd_gallery_$id parameter. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.

📍 영향받는 시스템

WordPress Gallery plugin versions up to and including 1.3

⚔️ 공격 벡터

Authenticated attackers with Contributor-level access or higher inject PHP objects via the wd_gallery_$id parameter

🛡️ 대응 방법

Update Gallery plugin to version 1.4 or later and verify no vulnerable POP chains exist in other installed plugins/themes

🔧 검증 코드

If output shows version 1.3 or lower, Gallery plugin is vulnerable and requires immediate update; empty result means plugin is not installed

Shell / Script
grep -r "Version" wp-content/plugins/gallery 2>/dev/null | head -1

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

PHP