🇰🇷 한글 설명
Apache Tomcat에서 민감한 정보가 포함된 오류 메시지가 생성되는 취약점입니다. 이 문제는 특정 버전의 Apache Tomcat에서 발생하며, 공격자가 시스템 내부 정보를 탈취하는 데 악용될 수 있습니다.
💡 쉬운 설명
프로그램이 오류를 일으킬 때, 원래는 숨겨야 할 중요한 내부 정보가 화면에 그대로 노출되는 문제입니다. 해커는 이 정보를 통해 서버의 구조나 설정 등을 파악할 수 있습니다.
🇺🇸 원문 (English)
Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat.This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43. Other, EOL versions may also be affected.
Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.
📍 영향받는 시스템
Apache Tomcat 8.5.7 ~ 8.5.63, 9.0.0-M11 ~ 9.0.43 및 기타 EOL 버전
⚔️ 공격 벡터
특정 조건에서 오류를 유도하여 서버가 출력하는 에러 메시지 내의 민감 정보를 탈취
🛡️ 대응 방법
Apache Tomcat을 8.5.64 또는 9.0.44 이상의 버전으로 업그레이드
🔧 검증 코드
명령어 결과에 취약한 버전 범위가 출력되면 해당 버전이 설치되어 있는 상태입니다.
java -jar tomcat-version-check.jar 2>/dev/null | grep -E '8.5\.(7|[0-9]{2})|9.0\.(0-M11|[0-9]{2})'