🔍 CVE-2024-24812

5.4
CVSS Score
MEDIUM
2024-02-07
2026-06-17 07:14
✅ 완료

🇰🇷 한글 설명

Frappe 프레임워크의 포털 페이지에서 교차 사이트 스크립팅(XSS) 취약점이 발견되었습니다. 공격자가 악성 링크를 통해 사용자에게 악성 자바스크립트 코드를 실행시킬 수 있습니다. 이 문제는 버전 14.59.0 및 15.5.0 미만 버전에서 발생합니다.

💡 쉬운 설명

사용자가 나쁜 의도로 만들어진 링크를 클릭하면, 웹사이트가 사용자의 브라우저에서 몰래 악성 코드를 실행할 수 있는 보안 약점입니다. 이를 통해 개인정보가 유출되거나 계정이 탈취될 위험이 있습니다.

🇺🇸 원문 (English)

Frappe is a full-stack web application framework that uses Python and MariaDB on the server side and a tightly integrated client side library. Prior to versions 14.59.0 and 15.5.0, portal pages are susceptible to Cross-Site Scripting (XSS) which can be used to inject malicious JS code if user clicks on a malicious link. This vulnerability has been patched in versions 14.59.0 and 15.5.0. No known workarounds are available.

📍 영향받는 시스템

Frappe Framework versions prior to 14.59.0 and 15.5.0

⚔️ 공격 벡터

사용자가 공격자가 생성한 악성 링크를 클릭하도록 유도하는 방식

🛡️ 대응 방법

Frappe 프레임워크를 버전 14.59.0 또는 15.5.0 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 버전이 14.59.0 또는 15.5.0보다 낮은지 확인하십시오.

Shell / Script
pip show frappe | grep Version

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

💻 영향받는 소프트웨어

MariaDB