🔍 CVE-2024-26787

5.5
CVSS Score
MEDIUM
2024-04-04
2026-10-15 01:17
✅ 완료

🇰🇷 한글 설명

Linux 커널 MMC 드라이버에서 DMA 매핑이 제대로 해제되지 않는 메모리 누수 취약점입니다. STM32 변형에서 오류 발생 시 dma_unmap_sg가 호출되지 않아 반복적인 DMA 매핑으로 인한 자원 고갈 및 서비스 거부 공격이 가능합니다.

💡 쉬운 설명

Linux 커널의 메모리 카드 드라이버가 할당한 메모리를 제대로 해제하지 못하는 버그입니다. 공격자가 오류 상황을 반복적으로 유발하면 메모리가 고갈되어 시스템이 다운될 수 있습니다.

🇺🇸 원문 (English)

In the Linux kernel, the following vulnerability has been resolved: mmc: mmci: stm32: fix DMA API overlapping mappings warning Turning on CONFIG_DMA_API_DEBUG_SG results in the following warning: DMA-API: mmci-pl18x 48220000.mmc: cacheline tracking EEXIST, overlapping mappings aren't supported WARNING: CPU: 1 PID: 51 at kernel/dma/debug.c:568 add_dma_entry+0x234/0x2f4 Modules linked in: CPU: 1 PID: 51 Comm: kworker/1:2 Not tainted 6.1.28 #1 Hardware name: STMicroelectronics STM32MP257F-EV1 Evaluation Board (DT) Workqueue: events_freezable mmc_rescan Call trace: add_dma_entry+0x234/0x2f4 debug_dma_map_sg+0x198/0x350 __dma_map_sg_attrs+0xa0/0x110 dma_map_sg_attrs+0x10/0x2c sdmmc_idma_prep_data+0x80/0xc0 mmci_prep_data+0x38/0x84 mmci_start_data+0x108/0x2dc mmci_request+0xe4/0x190 __mmc_start_request+0x68/0x140 mmc_start_request+0x94/0xc0 mmc_wait_for_req+0x70/0x100 mmc_send_tuning+0x108/0x1ac sdmmc_execute_tuning+0x14c/0x210 mmc_execute_tuning+0x48/0xec mmc_sd_init_uhs_card.part.0+0x208/0x464 mmc_sd_init_card+0x318/0x89c mmc_attach_sd+0xe4/0x180 mmc_rescan+0x244/0x320 DMA API debug brings to light leaking dma-mappings as dma_map_sg and dma_unmap_sg are not correctly balanced. If an error occurs in mmci_cmd_irq function, only mmci_dma_error function is called and as this API is not managed on stm32 variant, dma_unmap_sg is never called in this error path.

📍 영향받는 시스템

Linux kernel < 6.1.28, STM32 MMC/SDMMC controller (stm32 variant in mmci driver)

⚔️ 공격 벡터

Trigger repeated MMC controller errors or command timeouts to exhaust kernel DMA memory and cause denial of service

🛡️ 대응 방법

Update Linux kernel to version 6.1.28 or later; apply patch to properly call dma_unmap_sg in mmci_dma_error for all variants

🔧 검증 코드

Output 'Vulnerable' indicates kernel version below 6.1.28 is installed; 'Patched' indicates safe version. Cross-reference with dmesg | grep -i 'DMA-API' to confirm if warnings are present.

Shell / Script
uname -r | cut -d. -f1-3 | awk -F. '{if(($1<6)||($1==6&&$2<1)||($1==6&&$2==1&&$3<28)){print "Vulnerable"}else{print "Patched"}}'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

Linux Kernel