🇰🇷 한글 설명
Pulsar Function Worker의 부적절한 입력 검증으로 인해 인증된 공격자가 샌드박스를 벗어나 임의의 Java 코드를 실행할 수 있습니다. 이 취약점은 functionsWorkerEnabled 설정이 활성화된 Pulsar Broker에도 적용됩니다.
💡 쉬운 설명
권한을 가진 사용자가 시스템의 제한된 구역을 넘어 서버 전체를 마음대로 조종할 수 있는 보안 구멍이 발견되었습니다. 이를 통해 공격자는 서버에 악성 코드를 심거나 데이터를 탈취할 수 있습니다.
🇺🇸 원문 (English)
Improper input validation in the Pulsar Function Worker allows a malicious authenticated user to execute arbitrary Java code on the Pulsar Function worker, outside of the sandboxes designated for running user-provided functions. This vulnerability also applies to the Pulsar Broker when it is configured with "functionsWorkerEnabled=true".
This issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0.
2.10 Pulsar Function Worker users should upgrade to at least 2.10.6.
2.11 Pulsar Function Worker users should upgrade to at least 2.11.4.
3.0 Pulsar Function Worker users should upgrade to at least 3.0.3.
3.1 Pulsar Function Worker users should upgrade to at least 3.1.3.
3.2 Pulsar Function Worker users should upgrade to at least 3.2.1.
Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
📍 영향받는 시스템
Apache Pulsar 2.4.0~2.10.5, 2.11.0~2.11.3, 3.0.0~3.0.2, 3.1.0~3.1.2, 3.2.0
⚔️ 공격 벡터
인증된 사용자가 조작된 입력을 통해 Function Worker의 샌드박스를 우회하여 임의의 Java 코드 실행
🛡️ 대응 방법
Pulsar 버전을 2.10.6, 2.11.4, 3.0.3, 3.1.3, 3.2.1 이상으로 즉시 업그레이드
🔧 검증 코드
출력된 Apache Pulsar 버전을 확인하여 취약한 버전 범위에 포함되는지 대조합니다.
pulsar-admin cluster list 2>/dev/null | grep -i 'version' || apache-pulsar --version