🔍 CVE-2024-28148

4.3
CVSS Score
MEDIUM
2024-05-07
2026-06-17 07:21
✅ 완료

🇰🇷 한글 설명

인증된 사용자가 특정 REST API 요청을 전송하여 권한이 없는 데이터 소스의 메타데이터에 접근할 수 있는 취약점입니다. 이 문제는 Apache Superset 3.1.2 미만 버전에서 발생합니다.

💡 쉬운 설명

로그인한 사용자가 허락되지 않은 데이터 정보를 몰래 훔쳐볼 수 있는 보안 결함입니다. 이를 방지하기 위해 소프트웨어를 최신 버전으로 업데이트해야 합니다.

🇺🇸 원문 (English)

An authenticated user could potentially access metadata for a datasource they are not authorized to view by submitting a targeted REST API request.This issue affects Apache Superset: before 3.1.2. Users are recommended to upgrade to version 3.1.2 or above, which fixes the issue.

📍 영향받는 시스템

Apache Superset 3.1.2 미만 모든 버전

⚔️ 공격 벡터

인증된 사용자가 조작된 REST API 요청을 전송하여 권한 검증을 우회함

🛡️ 대응 방법

Apache Superset을 3.1.2 버전 이상으로 업그레이드

🔧 검증 코드

출력된 버전 번호가 3.1.2보다 낮은지 확인합니다.

Shell / Script
pip show apache-superset | grep Version

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

💻 영향받는 소프트웨어

Spring Data REST