🇰🇷 한글 설명
인증된 사용자가 권한을 초과하여 파티션된 토픽에 대한 관리 작업(언로딩, 컴팩션 등)을 수행하거나 네임스페이스 속성을 임의로 조작할 수 있는 취약점입니다. 이로 인해 권한이 없는 사용자가 구독을 생성하거나 네임스페이스 메타데이터를 읽고, 생성, 수정, 삭제할 수 있습니다.
💡 쉬운 설명
일반 사용자에게 허용된 권한보다 훨씬 높은 관리자 수준의 권한을 행사할 수 있는 보안 결함입니다. 이를 통해 데이터 관리 설정을 마음대로 바꾸거나 시스템의 메타데이터를 조작할 위험이 있습니다.
🇺🇸 원문 (English)
This vulnerability allows authenticated users with produce or consume permissions to perform unauthorized operations on partitioned topics, such as unloading topics and triggering compaction. These management operations should be restricted to users with the tenant admin role or superuser role. An authenticated user with produce permission can create subscriptions and update subscription properties on partitioned topics, even though this should be limited to users with consume permissions. This impact analysis assumes that Pulsar has been configured with the default authorization provider. For custom authorization providers, the impact could be slightly different. Additionally, the vulnerability allows an authenticated user to read, create, modify, and delete namespace properties in any namespace in any tenant. In Pulsar, namespace properties are reserved for user provided metadata about the namespace.
This issue affects Apache Pulsar versions from 2.7.1 to 2.10.6, from 2.11.0 to 2.11.4, from 3.0.0 to 3.0.3, from 3.1.0 to 3.1.3, and from 3.2.0 to 3.2.1.
3.0 Apache Pulsar users should upgrade to at least 3.0.4.
3.1 and 3.2 Apache Pulsar users should upgrade to at least 3.2.2.
Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
📍 영향받는 시스템
Apache Pulsar 2.7.1-2.10.6, 2.11.0-2.11.4, 3.0.0-3.0.3, 3.1.0-3.1.3, 3.2.0-3.2.1
⚔️ 공격 벡터
produce 또는 consume 권한을 가진 인증된 사용자가 권한 검증 미흡을 악용하여 관리 명령을 실행
🛡️ 대응 방법
Apache Pulsar를 3.0.4, 3.2.2 또는 그 이상의 최신 패치 버전으로 업그레이드
🔧 검증 코드
출력된 버전이 취약한 버전 범위에 포함되는지 확인하여 업그레이드 필요 여부를 판단합니다.