🇰🇷 한글 설명
Apache HTTP Server 2.4.59 및 이전 버전의 mod_proxy에서 인코딩 문제가 발생하여 잘못된 인코딩의 요청 URL이 백엔드 서비스로 전달될 수 있습니다. 이를 통해 공격자가 정교하게 조작된 요청을 보내 인증을 우회할 가능성이 있습니다.
💡 쉬운 설명
웹 서버가 주소를 해석할 때 글자 인코딩을 잘못 처리하는 허점이 발견되었습니다. 공격자가 이 허점을 이용해 특수하게 만든 주소를 보내면, 보안 검사를 통과하여 서버 내부로 몰래 들어올 수 있습니다.
🇺🇸 원문 (English)
Encoding problem in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows request URLs with incorrect encoding to be sent to backend services, potentially bypassing authentication via crafted requests.
Users are recommended to upgrade to version 2.4.60, which fixes this issue.
📍 영향받는 시스템
Apache HTTP Server 2.4.59 및 그 이전 모든 버전
⚔️ 공격 벡터
잘못된 인코딩이 포함된 조작된 URL 요청을 통해 인증 우회 시도
🛡️ 대응 방법
Apache HTTP Server를 보안 패치가 적용된 2.4.60 버전 이상으로 업그레이드
🔧 검증 코드
출력된 버전이 Apache/2.4.59 이하이면 취약한 상태이며, 2.4.60 이상이어야 안전합니다.
httpd -v 2>/dev/null || apache2 -v 2>/dev/null | grep -E 'Apache/2.4.[0-5][0-9]'