🔍 CVE-2024-38477

7.5
CVSS Score
HIGH
2024-07-01
2026-06-17 07:40
✅ 완료

🇰🇷 한글 설명

Apache HTTP Server 2.4.59 및 이전 버전의 mod_proxy 모듈에서 발생하는 Null 포인터 역참조 취약점입니다. 공격자가 악의적인 요청을 보내 서버를 강제로 종료(Crash)시킬 수 있습니다.

💡 쉬운 설명

서버가 처리할 수 없는 잘못된 요청을 받으면 프로그램이 갑자기 멈춰버리는 문제입니다. 이로 인해 웹사이트 서비스가 중단될 수 있습니다.

🇺🇸 원문 (English)

null pointer dereference in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows an attacker to crash the server via a malicious request. Users are recommended to upgrade to version 2.4.60, which fixes this issue.

📍 영향받는 시스템

Apache HTTP Server 2.4.59 및 그 이전 모든 버전

⚔️ 공격 벡터

조작된 HTTP 요청을 통한 mod_proxy 모듈 공격

🛡️ 대응 방법

Apache HTTP Server를 2.4.60 버전 이상으로 업그레이드

🔧 검증 코드

출력된 버전 번호가 2.4.60 미만이면 취약한 상태입니다.

Shell / Script
httpd -v 2>/dev/null || apache2 -v 2>/dev/null | grep -oE 'Apache/[0-9.]+'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

Apache HTTP Server