🔍 CVE-2024-39573

7.5
CVSS Score
HIGH
2024-07-01
2026-06-17 07:42
✅ 완료

🇰🇷 한글 설명

Apache HTTP Server 2.4.59 및 이전 버전의 mod_rewrite 모듈에서 잠재적인 SSRF(서버 측 요청 위조) 취약점이 발견되었습니다. 공격자는 안전하지 않은 RewriteRules를 사용하여 URL이 의도치 않게 mod_proxy에 의해 처리되도록 유도할 수 있습니다.

💡 쉬운 설명

웹 서버의 주소 변환 규칙을 악용하여, 공격자가 서버 내부나 외부의 다른 주소로 몰래 요청을 보내게 만드는 취약점입니다. 이를 통해 서버가 허용되지 않은 곳에 접속하게 만들 수 있습니다.

🇺🇸 원문 (English)

Potential SSRF in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows an attacker to cause unsafe RewriteRules to unexpectedly setup URL's to be handled by mod_proxy. Users are recommended to upgrade to version 2.4.60, which fixes this issue.

📍 영향받는 시스템

Apache HTTP Server 2.4.59 및 그 이전 모든 버전

⚔️ 공격 벡터

조작된 RewriteRules를 통해 URL을 mod_proxy가 처리하도록 유도하는 방식

🛡️ 대응 방법

Apache HTTP Server를 취약점이 해결된 2.4.60 버전 이상으로 업그레이드하십시오.

🔧 검증 코드

출력된 버전이 2.4.60 미만(예: 2.4.59 이하)이면 취약한 상태입니다.

Shell / Script
httpd -v 2>/dev/null || apache2 -v 2>/dev/null | grep -E 'Apache/2\.(4\.[0-59])'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

💻 영향받는 소프트웨어

Apache HTTP Server