🔍 CVE-2024-45409

10.0
CVSS Score
CRITICAL
2024-09-10
2026-11-04 00:17
✅ 완료

🇰🇷 한글 설명

Ruby-SAML 라이브러리는 SAML 인증의 클라이언트 측 구현에 사용됩니다. 버전 12.2 이하 및 1.13.0~1.16.0에서는 SAML Response의 서명을 제대로 검증하지 않아, 서명된 SAML 문서에 접근할 수 있는 인증되지 않은 공격자가 임의의 내용을 가진 SAML Response/Assertion을 위조할 수 있습니다. 이를 통해 공격자는 취약한 시스템에서 임의의 사용자로 로그인할 수 있습니다. 1.17.0 및 1.12.3 버전에서 수정되었습니다.

💡 쉬운 설명

SAML은 회사나 서비스에서 한 번의 로그인으로 여러 시스템을 쓰게 해주는 인증 방식입니다. 이 취약점을 이용하면 공격자가 가짜 로그인 증명서를 만들어 다른 사람인 척 시스템에 들어갈 수 있습니다.

🇺🇸 원문 (English)

The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.

📍 영향받는 시스템

Ruby-SAML 12.2 이하 및 1.13.0~1.16.0 버전을 사용하는 Ruby 기반 SAML 인증 애플리케이션

⚔️ 공격 벡터

IdP가 서명한 SAML 문서를 확보한 인증되지 않은 공격자가 서명 검증 우회로 임의 사용자의 SAML Response/Assertion을 위조하여 로그인

🛡️ 대응 방법

ruby-saml을 1.17.0 이상 또는 1.12.3 이상으로 업데이트

🔧 검증 코드

출력된 버전이 1.17.0 이상 또는 1.12.3 이상이면 안전하며, 12.2 이하 또는 1.13.0~1.16.0이면 취약하므로 즉시 업데이트가 필요합니다.

Shell / Script
gem list ruby-saml 2>/dev/null | grep -E 'ruby-saml'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N