🔍 CVE-2025-11993

8.8
CVSS Score
HIGH
2026-05-29
2026-07-21 12:10
✅ 완료

🇰🇷 한글 설명

WooCommerce Infinite Scroll and Ajax Pagination 플러그인의 'import_settings' 함수에서 신뢰할 수 없는 데이터를 보안 확인 없이 역직렬화하여 PHP 객체 주입 취약점이 발생합니다. 구독자(Subscriber) 이상의 권한을 가진 인증된 공격자가 악의적인 객체를 주입하여, 다른 플러그인/테마의 POP 체인을 활용하면 임의 파일 삭제, 민감 정보 탈취, 코드 실행이 가능합니다.

💡 쉬운 설명

WordPress WooCommerce 플러그인에서 설정 가져오기 기능이 안전하지 않은 방식으로 데이터를 처리합니다. 일반 사용자 권한만으로도 악의적인 명령을 실행할 수 있습니다.

🇺🇸 원문 (English)

The WooCommerce Infinite Scroll and Ajax Pagination plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.8 via the 'settings' parameter in the 'import_settings' function. This is due to deserialization of untrusted data supplied via the import configuration feature without capability checks. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject a PHP Object. No POP chain is present within the vulnerable plugin itself, but if a POP chain is present via an additional plugin or theme installed on the target system, it could allow an attacker to delete arbitrary files, retrieve sensitive data, or execute code.

📍 영향받는 시스템

WooCommerce Infinite Scroll and Ajax Pagination plugin version 1.8 and below

⚔️ 공격 벡터

Authenticated attacker with Subscriber-level or higher access uploads malicious serialized PHP object via import_settings feature to trigger code execution or file operations

🛡️ 대응 방법

Update plugin to version 1.8.1 or higher, implement input validation and capability checks for import_settings function, consider disabling import feature if unused

🔧 검증 코드

Output shows installed version; if version is 1.8 or lower, system is vulnerable. If version is 1.8.1+, patch has been applied.

Shell / Script
grep -i 'Version' /var/www/html/wp-content/plugins/infinite-scroll-and-ajax-pagination/*.php 2>/dev/null | grep -v 'stable tag'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

PHP