🔍 CVE-2025-12377

4.3
CVSS Score
MEDIUM
2025-11-13
2026-10-07 21:10
✅ 완료

🇰🇷 한글 설명

WordPress용 Envira Photo Gallery 플러그인의 모든 버전(1.12.0 포함)에서 권한 확인 미흡으로 인해 데이터가 무단 수정될 수 있는 취약점이 발견되었습니다. 이로 인해 작성자(Author) 이상의 권한을 가진 인증된 공격자가 임의의 갤러리에서 이미지를 삭제하는 등의 작업을 수행할 수 있습니다.

💡 쉬운 설명

워드프레스 사진 갤러리 플러그인에서 권한 검사가 제대로 이루어지지 않아 발생하는 문제입니다. 글을 쓸 수 있는 권한만 있어도 다른 사람이 만든 사진첩의 사진을 마음대로 지울 수 있습니다.

🇺🇸 원문 (English)

The Gallery Plugin for WordPress – Envira Photo Gallery plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on several functions in all versions up to, and including, 1.12.0. This makes it possible for authenticated attackers, with Author-level access and above, to perform multiple actions, such as removing images from arbitrary galleries. The vulnerability was partially patched in version 1.12.0.

📍 영향받는 시스템

Envira Photo Gallery plugin for WordPress (v1.12.0 및 그 이하 모든 버전)

⚔️ 공격 벡터

작성자(Author) 이상의 권한을 가진 인증된 사용자가 권한 검사가 누락된 함수를 호출하여 공격

🛡️ 대응 방법

플러그인을 최신 보안 패치가 적용된 버전으로 업데이트하십시오.

🔧 검증 코드

출력된 버전 번호가 1.12.0 이하이면 취약한 상태입니다.

Shell / Script
wp plugin list --name envira-gallery --format=json | grep -oP '(?<=version\":")[^"]+'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

💻 영향받는 소프트웨어

WordPress