🔍 CVE-2025-12499

7.2
CVSS Score
HIGH
2025-12-06
2026-10-15 20:10
✅ 완료

🇰🇷 한글 설명

WordPress용 Rich Shortcodes for Google Reviews 플러그인 6.8 버전 이하에서 저장형 XSS 취약점이 발견되었습니다. 구글 리뷰 콘텐츠에 대한 입력값 검증 및 출력 이스케이프 처리가 미흡하여, 인증되지 않은 공격자가 악성 스크립트를 삽입할 수 있습니다. 이 스크립트는 사용자가 해당 페이지에 접속할 때마다 실행됩니다.

💡 쉬운 설명

구글 리뷰를 보여주는 플러그인에 악성 코드를 숨겨 넣을 수 있는 보안 구멍이 발견되었습니다. 공격자가 리뷰 내용에 나쁜 코드를 심어두면, 웹사이트 방문자의 정보를 훔치거나 원치 않는 동작을 실행할 수 있습니다.

🇺🇸 원문 (English)

The Rich Shortcodes for Google Reviews plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the contents of a Google Review in all versions up to, and including, 6.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability was partially patched in version 6.6.2.

📍 영향받는 시스템

Rich Shortcodes for Google Reviews plugin (WordPress) version 6.8 and below

⚔️ 공격 벡터

구글 리뷰 콘텐츠 내에 악성 스크립트를 삽입하여 저장하는 방식 (Stored XSS)

🛡️ 대응 방법

플러그인을 최신 버전(6.6.2 이상 패치 확인 및 최신 업데이트)으로 즉시 업데이트하십시오.

🔧 검증 코드

출력된 플러그인 목록에서 해당 플러그인의 버전을 확인하여 6.8 이하인지 체크하십시오.

Shell / Script
wp plugin list --status=active | grep -i 'rich-shortcodes-for-google-reviews'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

💻 영향받는 소프트웨어

WordPress