🔍 CVE-2025-12664

7.5
CVSS Score
HIGH
2026-04-08
2026-07-25 11:10
✅ 완료

🇰🇷 한글 설명

GitLab CE/EE의 13.0 이상 18.8.9 미만, 18.9 이상 18.9.5 미만, 18.10 이상 18.10.3 미만 버전에서 인증되지 않은 사용자가 반복적인 GraphQL 쿼리를 통해 서비스 거부(DoS) 공격을 수행할 수 있는 취약점이 존재합니다.

💡 쉬운 설명

GitLab 웹서버가 로그인하지 않은 공격자의 과도한 GraphQL 요청에 대응하지 못하면서 정상 사용자가 서비스를 이용할 수 없게 됩니다. GraphQL API가 요청 제한 없이 실행되면서 서버 리소스가 고갈됩니다.

🇺🇸 원문 (English)

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 13.0 before 18.8.9, 18.9 before 18.9.5, and 18.10 before 18.10.3 that could have allowed an unauthenticated user to cause denial of service by sending repeated GraphQL queries.

📍 영향받는 시스템

GitLab CE/EE v13.0-18.8.8, v18.9.0-18.9.4, v18.10.0-18.10.2

⚔️ 공격 벡터

Unauthenticated GraphQL query flooding to /api/graphql endpoint

🛡️ 대응 방법

Upgrade to GitLab 18.8.9, 18.9.5, 18.10.3 or later versions

🔧 검증 코드

표시되는 GitLab 버전이 18.8.9, 18.9.5, 18.10.3 미만이면 취약하며 즉시 패치 필요

Shell / Script
gitlab-rake gitlab:env:info 2>/dev/null | grep -i 'gitlab version' || dpkg -l 2>/dev/null | grep gitlab

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H